Blog change

October 21, 2011

This blog has moved to http://renatogarcia.blog.br

This blog has moved to http://renatogarcia.blog.br

And this post to http://renatogarcia.blog.br/en/posts/compiling-artoolkitplus-2-1-1.html

20 Mar 2011 – Updated to correct an error in file arDetectMarker.cxx when using gcc 4.5

The ARToolKitPlus library isn’t developed anymore since June 2006. Nowadays is a pain compile it, there are errors with gcc 4.4, it uses the qmake builder of kde 3 series, and there are errors on internal includes. To solve this I make any patches and one project in SCons, which is better than qmake, IMO, and have less dependencies.

If you use Arch Linux there are one package in AUR with that changes, else, follow this steps:

Download the package in Arch AUR (here) and the ARToolKitPlus source (here). Put them in a same empty directory.

Run the following commands:

$>tar -xvzf artoolkitplus.tar.gz
$>unzip ARToolKitPlus_2.1.1.zip -d artoolkitplus
$>cd artoolkitplus
$>mv sample_multi_SConscript sample/multi/SConscript
$>mv sample_simple_SConscript sample/simple/SConscript
$>mv src_SConscript src/SConscript
$>mv tools_IdPatGen_SConscript tools/IdPatGen/SConscript
$>patch -p0 < gcc45.patch
$>scons install prefix=$(echo ${PWD%/*})/pkg/usr
$>mv include.patch ..
$>cd ..
$>patch -p0 < include.patch

Logically you must have Scons installed. If all goes well the ARTKP is compiled inside pkg directory.